Jump to content

Site errors


tm4tj

Recommended Posts

There have been a few times I’ve got that message and other times the site has been slow to load. Haven’t noticed an increase in adverts though. 

Link to comment
Share on other sites

10 hours ago, Robert said:

There have been a few times I’ve got that message and other times the site has been slow to load. Haven’t noticed an increase in adverts though. 

The same for me. 

Link to comment
Share on other sites

Timed out again on me today. Pain in the ar5e when trying to edit/add articles. scotty aware and checking over stuff.

  • Thank You 1
Link to comment
Share on other sites

spoke with TM4TJ and most errors he gets are 522 errors. These are a nightmare to try and troubleshoot as its basically a connection error and that could range anywhere from the server being down to high traffic to firewall issues and a host of other technical issues. It can last for a fraction of a second or can be a prolonged problem. it's quite literally a digital needle in the haystack.  522 is a server-side error so it's not your connection, your provider or anything else on your side, it is the server. I will continue to look into it but pinning it down may be more to do with luck than any specific course of definitive action! I know our stats program can be a little heavy on resources as its using an old version of PHP but unfortunately, I am a little outside my scope trying to upgrade this myself so if anyone does have some mad PHP/MySQL skills please step forward 🙂

W/regards to the ads - Our revenue has gone down nearly 80% in the last 6 months using what Google call "Auto-Ads". These are ads that are placed by them, optimized for size and position. These are still in place, but I have been trying to get revenue back up by placing them manually on pages where the auto-ads do not work. I have also enabled a adblocker message asking users to not block ads so if you have them blocked you may see this. If we don't make money from the ads, there will be no site, it's that simple. We have not used £10 shared hosting in a long time, and it costs somewhere close to US$2000 per year to host this site on a VPS server and pay for software maintenance, support and all other ancillary costs like domains and other stuff. I vowed to myself and family that while self-financing I would keep it going. Once it becomes a drain on personal finances then my options are limited and pulling the plug is a real possibility. Been doing it 28 years so it's not a bad run if it ends... although 30 is a nice number too and I am shooting for that (and beyond) if I can 🙂 I have resisted the temptation to reinstate the "Vignette Ads" which Google keep telling me would increase revenue by 50% as it is clear from the first foray with Auto Ads that people don't like them and if people stay away because of the ads then 50% of $0 is $0! I will continue to review the ad situation and try to strike a balance between revenue and usability. I also get almost daily offers for "paid content" where I would get paid to publish betting or other spammy articles. We turn them all down (by ignoring them) purely because we have always thought "content is king". 

If anyone wants to help out with costs, donations are gratefully accepted, or you could become a "site sponsor" for £25 per year which removes all ads from your experience. Also - If anyone is able to set us up with a corporate sponsor then even better and you may get a few perks in return... 

 

 

  • Thank You 2
Link to comment
Share on other sites

On 10/14/2022 at 3:54 PM, Scotty said:

spoke with TM4TJ and most errors he gets are 522 errors. These are a nightmare to try and troubleshoot as its basically a connection error and that could range anywhere from the server being down to high traffic to firewall issues and a host of other technical issues. It can last for a fraction of a second or can be a prolonged problem. it's quite literally a digital needle in the haystack.  522 is a server-side error so it's not your connection, your provider or anything else on your side, it is the server.

Yes, I too have been suffering long response times, and getting 522 errors.  Do you see this behaviour too, Scotty, when coming in as a normal user?  If not, that might suggest the problem is not actually the server, but something on the route to the UK.

If I remember, next time it's bad I'll run a traceroute, and see if that tells us anything.

Link to comment
Share on other sites

2 hours ago, snorbens_caleyman said:

If I remember, next time it's bad I'll run a traceroute, and see if that tells us anything.

Well that didn't tell me anything.  Just had a very slow few minutes and then a 522, so I ran a traceroute.

traceroute.jpg.959944c3ed16b516be9e1e7bd686845d.jpg

Hops 2,3 and 4 are at my ISP, Zen Internet.  Hop 5 is to the London Internet Exchange, LINX.  Hops 6 and 7 are to Cloudflare addresses. 

I actually got this at the very same time as my browser was unsuccessfully trying to refresh caleythistleonline - it eventually failed and gave me a 522.

There is always a significant pause between hops 5 and 6, even when the website is loading quickly.

Instead of a timeout error, I sometimes get an old version of the website - a few days old.  Not sure why this should happen, because I would have thought that Cloudflare would have an up-to-date cache.

Incidentally, I had to make three attempts to upload the image above - was getting "unknown server error", code -200.  I have no idea if that is another symptom of the same problem.

Sorry, but I don't think this will help much.

Edited by snorbens_caleyman
deleting superseded images / "old version" info
Link to comment
Share on other sites

1 hour ago, snorbens_caleyman said:

Well that didn't tell me anything.  Just had a very slow few minutes and then a 522, so I ran a traceroute.

traceroute.jpg.959944c3ed16b516be9e1e7bd686845d.jpg

Hops 2,3 and 4 are at my ISP, Zen Internet.  Hop 5 is to the London Internet Exchange, LINX.  Hops 6 and 7 are to Cloudflare addresses. 

I actually got this at the very same time as my browser was unsuccessfully trying to refresh caleythistleonline - it eventually failed and gave me a 522.

There is always a significant pause between hops 5 and 6, even when the website is loading quickly.

Instead of a timeout error, I sometimes get an old version of the website - a few days old.  Not sure why this should happen, because I would have thought that Cloudflare would have an up-to-date cache.

Incidentally, I had to make three attempts to upload the image above - was getting "unknown server error", code -200.  I have no idea if that is another symptom of the same problem.

Sorry, but I don't think this will help much.

Actually - and with all due respect to others - this helps me a lot more than the other responses as it gives me details. 522 errors are almost impossible to resolve unless you get lucky. They are also known colloquially as "Cloudflare errors" and can occur due to issues on the server itself or between Cloudflare and the Server. They are not typically a problem on the end user machine. We are hosted in Chicago as that's where our service provider is located. We use Cloudflare for security and also so that it's distributed on their network so theoretically you pick up a UK based copy of the website rather than from our provider in the USA.

I am going to have to pause Cloudflare to test further but before I do that I will need to do some security tweaks as we use CLoudflare for SSL also. I will essentially go back to square one on the host and try to make sure each step of the way is working. May take a little time.    

  • Thank You 1
Link to comment
Share on other sites

Ooooooooffffffttttt

I don't know what you did Scotty, but the site is going like a rocket now. I can't type quick enough to keep pace with it.

Cheers.

Not one error tonight and got a shitload done. Happy days.

Link to comment
Share on other sites

33 minutes ago, tm4tj said:

Ooooooooffffffttttt

I don't know what you did Scotty, but the site is going like a rocket now. I can't type quick enough to keep pace with it.

Cheers.

Not one error tonight and got a shitload done. Happy days.

mmm, sure I can fix that 🙂

  • Funny 3
Link to comment
Share on other sites

On 10/19/2022 at 10:39 PM, Scotty said:

Have made some tweaks. Please let me know of any continuing errors. 

Thanks Scotty, all good for me.

We appreciate all your efforts getting to the bottom of the issues. 

Link to comment
Share on other sites

Thought site was sluggish early on today, but just when i feared the worst it came good. Held my breath a couple of times but all good.

Link to comment
Share on other sites

4 hours ago, snorbens_caleyman said:

Wow!  Very different route, and it ends up at Liquid Web.  No sign of Cloudflare.  Have you moved the website, or was it always there but was "hidden" by Cloudflare?

Liquid Web is our host, always has been (well, since they took over our original host WiredTree) but we have used Cloudflare for domain registration, DNS and security since they came on the scene. I switched from using their proxy yesterday and updated our security certificates etc. so we should be good in those terms.

The simple fact is that when busy things will slow down, it's the nature of the beast, but hopefully the 522 errors are a thing of the past. 

 

Random Trivia: We were actually one of the first batch of sites to jump onboard with CloudFlare when they launched and even got featured on one of their T-Shirts that got sent to me. Its a Cloudflare logo but a bit like our black ICT shirt with people's names but in this instance, its domain names. CaleyThistleOnline.com is on there. I think BigDon is also on there. 🙂   

Link to comment
Share on other sites

Struggled last night to load Game 20 of the NPL. Tried again this morning with more struggles. Got it posted eventually. The 'submit' button wasn't highlighted and then the page and CTO in general failed to load. Came out of it and back in again. Same result. Third attempt I tried to post without ticking the Pin post button and adding the lock time / date. This worked and I got the thread posted. I then did the 'edit' to add pin/lock etc. I seemed to have a fooled it and/or forced it in to submission :twothumbsup:

Link to comment
Share on other sites

Bottom line - when the site is busy things can slow down. you have a large number of people accessing a finite number of resources and those are typically busiest after a game and the day after ... Looking at the CPU logs we did get a blip on Sunday, likely TM4TJ chewing up resurces using the stats program, but nothing that should have caused any outage.

With regard to the payment timeout, I cant duplicate the error on the shopping cart and the transaction itself takes place away from our site to ensure the relevant financial compliances and is done via paypal so outside our control. I will take a look and see if I can see anything in the logs, but another needle in a haystack. 

 

 

2022-10-24_13-19-49.jpg

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. : Terms of Use : Guidelines : Privacy Policy